Get in touch
Back
Maintenance

System Maintenance

Completed 28 Jan at 08:00pm CET.

Voicefinder Web Application Voicefinder Messenger
Completed

Maintenance completed

Posted 28 Jan at 08:00pm CET.
Started

We are improving security and overall site performance for all devices. Thank you for your understanding.

-The Voicefinder team

Posted 28 Jan at 06:00pm CET.